Edit this Doc The Selendroid Driver for Android

Note: This driver is DEPRECATED and should not be used unless absolutely necessary. The information in this doc may not keep up to date with reality, and the driver will be removed in a future version of Appium. To begin Android automation with Appium today, please use the UiAutomator2 Driver instead.

Appium's support for very old versions of Android (4.1 and below) comes via a project called Selendroid. Selendroid is an Instrumentation-based automation framework.

Development of the Selendroid driver happens at the appium-selendroid-driver repo.

Requirements and Support

In addition to Appium's general requirements:

Usage

The way to start a session using the Selendroid driver is to include the automationName capability in your new session request, with the value Selendroid. Of course, you must also include appropriate platformName (=Android), platformVersion, deviceName, and app capabilities, at a minimum.

It is highly recommended to also set the appPackage and appActivity capabilities in order to let Appium know exactly which package and activity should be launched for your application.

Capabilities

The Selendroid driver supports a subset of the standard Android capabilities.

Commands

Selendroid's API differs from Appium's other Android drivers significantly. We recommend you thoroughly read Selendroid's documentation before writing your scripts for older devices or hybrid apps.

Setup

Setup for the Selendroid driver basically entails getting the Android SDK and build tools ready to go. You can follow the instructions at the UiAutomator2 Driver doc, since the steps are the same.